summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-11-14 13:29:35 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-11-14 09:28:25 -0800
commit685b92b9c2ddd6575ae5df7c95b928e60fcd7005 (patch)
tree800b6b9cf4a744e318b0ff6b6e04b9e77143f602 /CMakeLists.txt
parentb43ecdad4ed956a3075ecb55aed4497217d011d9 (diff)
downloadsubsurface-685b92b9c2ddd6575ae5df7c95b928e60fcd7005.tar.gz
/: Corrected wrong Qt dependency from Kirigami
Kirigami 5.62 uses QtQuick.Controls 2.5, which were introduced in Qt 5.12 (see https://doc.qt.io/qt-5/qtquickcontrols-index.html) update CMakeList.txt to demand min. 5.12 when building SUBSURFACE-MOBILE update INSTALL text Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d618106d8..2d6a33126 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -251,8 +251,8 @@ set(QT_FIND_COMPONENTS Core Concurrent Widgets Network Svg Positioning Quick Loc
if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
find_package(Qt5 5.9.1 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
else()
- # Kirigami 5.62 and newer require at least Qt 5.11
- find_package(Qt5 5.11 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
+ # Kirigami 5.62 and newer require at least Qt 5.12
+ find_package(Qt5 5.12 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
endif()
foreach(_QT_COMPONENT ${QT_FIND_COMPONENTS})
list(APPEND QT_LIBRARIES Qt5::${_QT_COMPONENT})