summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-11-15 15:19:40 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-12-29 08:38:36 -0800
commitcdd3adc61b17c2cbced42b6753f141251f12152d (patch)
tree38eefb6bb937c2b2c82bf0f541ab1d2f8873776b /CMakeLists.txt
parent3fa2a6a5333bfe9fc5d0d39bd33cd647eb49b375 (diff)
downloadsubsurface-cdd3adc61b17c2cbced42b6753f141251f12152d.tar.gz
build-system: add QQuickWidgets to mobile build
Even though the mobile build doesn't have a UI for the statistics, yet, it already builds the base files. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0652fb5cc..470ecae0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -192,6 +192,7 @@ elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
set(SUBSURFACE_TARGET subsurface-mobile)
endif()
list(APPEND QT_EXTRA_COMPONENTS QuickControls2)
+ list(APPEND QT_EXTRA_COMPONENTS QuickWidgets)
add_definitions(-DSUBSURFACE_MOBILE)
# add definition to seperate mobile for devices and for desktop