summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-06-12 10:29:40 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-06-15 14:12:14 -0700
commitd0e9f626245e7833847ad25ae3b97c5ab87caccb (patch)
treeac760a0ae3134613db39b20dd2276dc52c2d8052 /CMakeLists.txt
parent54db1309a0896aa3615956e20a89bb71053a683f (diff)
downloadsubsurface-d0e9f626245e7833847ad25ae3b97c5ab87caccb.tar.gz
mobile: add qmlprefs class
add class to cmake and pro register class Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7b90f8318..75e2b0b9f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -285,6 +285,7 @@ endif()
if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
set(MOBILE_SRC
mobile-widgets/qmlmanager.cpp
+ mobile-widgets/qmlprefs.cpp
mobile-widgets/qml/kirigami/src/kirigamiplugin.cpp
mobile-widgets/qml/kirigami/src/settings.cpp
mobile-widgets/qml/kirigami/src/enums.cpp