summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Allen Hall <revenant83@hotmail.com>2018-04-11 17:04:38 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-04-23 09:31:11 -0700
commitd4d99b011628596b77bb7ffe532b60128d3cf9ee (patch)
tree69514725a0ebe1fb978044d8858c5d7be067aa7a /CMakeLists.txt
parent09edf25366e006dfca813b8af2533b32c15d0557 (diff)
downloadsubsurface-d4d99b011628596b77bb7ffe532b60128d3cf9ee.tar.gz
Add -libpath argument for qtmacdeploy
Resolves ERROR: no file at "/usr/lib/libgit2.dylib" when building on MacOS. [Dirk Hohndel: SOB in PR #1201 - copying it into the commit for consistenty] Signed-off-by: Allen Hall <revenant83@hotmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e550b6dd..f3b6c991d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -417,7 +417,7 @@ if(ANDROID)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(APP_BUNDLE_DIR "${SUBSURFACE_TARGET}.app")
set(EXTRA_MACDEPLOY_ARGS "-qmldir=${APP_BUNDLE_DIR}/Contents/Resources/qml ")
- set(MACDEPLOY_ARGS "${EXTRA_MACDEPLOY_ARGS}-executable=${APP_BUNDLE_DIR}/Contents/MacOS/${SUBSURFACE_TARGET} -always-overwrite")
+ set(MACDEPLOY_ARGS "${EXTRA_MACDEPLOY_ARGS}-executable=${APP_BUNDLE_DIR}/Contents/MacOS/${SUBSURFACE_TARGET} -always-overwrite -libpath=${CMAKE_SOURCE_DIR}/../install-root/lib")
set(RESOURCEDIR ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Resources)
set(PLUGINDIR ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/PlugIns)
install(DIRECTORY Documentation/images DESTINATION ${RESOURCEDIR}/share/Documentation)