summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-03-19 17:14:31 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-19 12:41:32 -0700
commitdc254716cf3a7e1289f6c72f7b3b90277d18359e (patch)
tree98ce612db0cd03257841d006dd7a8f09b1c3ea5b /CMakeLists.txt
parentd0acee4083f88926ed76c287e9836b14a82e163a (diff)
downloadsubsurface-dc254716cf3a7e1289f6c72f7b3b90277d18359e.tar.gz
CMake: call cmake_minimim_required() before project()
Some policies can affect how project() works. Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e07cadb1..99576a377 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,8 +3,8 @@
# Uncomment his to see all commands cmake actually executes
# set(CMAKE_VERBOSE_MAKEFILE ON)
-project(Subsurface)
cmake_minimum_required(VERSION 3.1)
+project(Subsurface)
# don't process generated files - this is new in 3.10
if (POLICY CMP0071)