summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-12-24 13:33:06 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-12-24 13:50:59 -0800
commitf067d3b5d67bcc7ee1bfec9b85d8dc8269b490c6 (patch)
treeab84c20a5df0c96b687524039f93af4ca61d5527 /CMakeLists.txt
parent726e231d6404e2383c0b29084c31027e5b0e5cc7 (diff)
downloadsubsurface-f067d3b5d67bcc7ee1bfec9b85d8dc8269b490c6.tar.gz
Fix build for cmake before 3.10
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5d7dd89c..011d4d776 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,8 +6,11 @@
project(Subsurface)
cmake_minimum_required(VERSION 2.8.11)
-# don't process generated files
-cmake_policy(SET CMP0071 OLD)
+# don't process generated files - this is new in 3.10 - but
+# VERSION_GREATER_EQUAL did get added until 3.7
+if(${CMAKE_VERSION} VERSION_EQUAL "3.10.0" OR ${CMAKE_VERSION} VERSION_GREATER "3.10.0")
+ cmake_policy(SET CMP0071 OLD)
+endif()
# global settings