summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Miika Turkia <miika.turkia@gmail.com>2016-01-02 14:26:23 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-01-04 10:00:44 -0800
commit164d2f8c071528b6d566aa308ccadde769934f06 (patch)
treeb26e57de88f51a17ea44f9988f68187fc2076ea3 /CMakeLists.txt
parent9cebcb836f840fbd6da6ad59426a5717c76cc342 (diff)
downloadsubsurface-164d2f8c071528b6d566aa308ccadde769934f06.tar.gz
Enable BT_SUPPORT compilation flag
We need to enable the BT_SUPPORT compilation flag to get the support built in. Signed-off-by: Miika Turkia <miika.turkia@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec0aa2caf..72adbc825 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -198,6 +198,10 @@ if (BTSUPPORT AND "${Qt5Core_VERSION_STRING}" STRLESS "5.4.0")
list(REMOVE_ITEM QT_LIBRARIES Qt5::Bluetooth)
endif()
+if(BTSUPPORT)
+ add_definitions(-DBT_SUPPORT)
+endif()
+
#set up the subsurface_link_libraries variable
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${LIBUSB_LIBRARIES})
qt5_add_resources(SUBSURFACE_RESOURCES subsurface.qrc)