summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-04-03 20:39:31 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-04-12 12:59:17 +0300
commit1f4777a2877e1df3215e03e48204333cb160a2c6 (patch)
tree82b1488e3033eaf9648128d04846817df0c735a3 /CMakeLists.txt
parentcf86ece73e6bc7fed2b251791f5e7e6103ee25cf (diff)
downloadsubsurface-1f4777a2877e1df3215e03e48204333cb160a2c6.tar.gz
CMake: move enable_testing() to the top level
This allows calling ctest from the main build directory instead of having to change one level down. As a bonus the unittests now show up in my KDevelop so I can directly run them from the IDE. Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 432030354..52347c458 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -530,6 +530,7 @@ elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
endif()
if (MAKE_TESTS)
+ enable_testing()
add_subdirectory(tests)
endif()