summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-11-17 19:22:02 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-16 08:00:31 -0800
commit69488596783779b31ad570065306980ff6dc4c92 (patch)
treea1f047deb57e14d26298bd63867afd5cbd19c91c /CMakeLists.txt
parent957f5532b8ae71cbecc486f52c0544895ae90304 (diff)
downloadsubsurface-69488596783779b31ad570065306980ff6dc4c92.tar.gz
Move include directories a bit down below
Better to follow the CMake logic and se those near the sources Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 10 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebe681cf4..6e0bd5d9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,18 +52,6 @@ set(CMAKE_MODULE_PATH
${${PROJECT_NAME}_SOURCE_DIR}/cmake/Modules
)
-include_directories(.
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${CMAKE_BINARY_DIR}/desktop-widgets
- desktop-widgets/
- qt-models
- desktop-widgets/profile
- subsurface-core/
-)
-
-message(STATUS "Creating build files for Subsurface")
-
#
# TODO: This Compilation part should go on the Target specific CMake.
#
@@ -108,6 +96,16 @@ if(SMARTTRAK_IMPORT)
pkg_config_library(LIBMDB libmdb REQUIRED)
endif()
+include_directories(.
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/desktop-widgets
+ desktop-widgets/
+ qt-models
+ desktop-widgets/profile
+ subsurface-core/
+)
+
if(ANDROID)
set(FBSUPPORT OFF)
set(NO_PRINTING ON)