summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Lubomir I. Ivanov <neolit123@gmail.com>2019-02-01 04:11:25 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-02-01 17:16:43 -0800
commita1ffe115cfb27bd0dd57bf5266c7d37d9ce64dab (patch)
tree6589e06ecce1d0c461900fd2537bf5125afadf9d /CMakeLists.txt
parent0c07b02974a65608d7d71ef150d322678ec1170b (diff)
downloadsubsurface-a1ffe115cfb27bd0dd57bf5266c7d37d9ce64dab.tar.gz
facebook: remove the featute from the code base
Remove from: - unit tests - desktop widgets - preferences - core intergration - cmakefiles - build scripts - icons - docs Also remove the plugins and social network integration. Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1556707e6..b431fd114 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,7 +40,6 @@ option(NO_PRINTING "disable the printing support" OFF)
option(NO_USERMANUAL "don't include a viewer for the user manual" OFF)
#Options regarding enabling parts of subsurface
-option(FBSUPPORT "allow posting to Facebook" ON)
option(BTSUPPORT "enable support for QtBluetooth (requires Qt5.4 or newer)" ON)
option(FTDISUPPORT "enable support for libftdi based serial" OFF)
option(USE_WEBENGINE "Use QWebEngine instead of QWebKit" OFF)
@@ -335,15 +334,10 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
add_executable(${SUBSURFACE_TARGET} MACOSX_BUNDLE WIN32 ${SUBSURFACE_PKG} ${SUBSURFACE_APP} ${SUBSURFACE_RESOURCES})
endif()
- if(FBSUPPORT)
- set(FACEBOOK_INTEGRATION facebook_integration)
- add_dependencies(facebook_integration subsurface_generated_ui)
- endif()
target_link_libraries(
${SUBSURFACE_TARGET}
subsurface_generated_ui
subsurface_interface
- ${FACEBOOK_INTEGRATION}
subsurface_profile
subsurface_statistics
subsurface_models_desktop