summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2016-01-07 10:22:31 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-01-07 10:22:31 -0800
commit0f311020205563823c71cfb68a77d156b14d352a (patch)
tree86e194874e0668fefb3c782cf14393bd141da43a /CMakeLists.txt
parentbb687f7f8bf97c02bbcda1066ad2d6f5a3542ed5 (diff)
downloadsubsurface-0f311020205563823c71cfb68a77d156b14d352a.tar.gz
Don't try to install Grantlee files when building Subsurface-mobile on Mac
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72adbc825..3f4d90d2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -347,7 +347,9 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
install(FILES ${QTTRANSLATIONS} DESTINATION ${RESOURCEDIR}/translations)
install(FILES ${CMAKE_SOURCE_DIR}/gpl-2.0.txt DESTINATION ${RESOURCEDIR})
# this is a HACK
- install(DIRECTORY ${Grantlee5_DIR}/../../grantlee DESTINATION ${PLUGINDIR})
+ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
+ install(DIRECTORY ${Grantlee5_DIR}/../../grantlee DESTINATION ${PLUGINDIR})
+ endif()
# this is a hack - but I don't know how else to find the macdeployqt program if it's not in the PATH
string(REPLACE moc macdeployqt MACDEPLOYQT ${QT_MOC_EXECUTABLE})
install(CODE "execute_process(COMMAND ${MACDEPLOYQT} ${APP_BUNDLE_DIR} ${MACDEPLOY_ARGS})")