summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-12-22 14:10:29 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-24 06:18:36 +0900
commit74755b64b169a7d161cd42c672ca45fcdeb5f028 (patch)
treebbbaa744d704467245bdb45f0b068a9b424c311a /CMakeLists.txt
parent41d6ff96c173e67654772537eeff3842dd024a53 (diff)
downloadsubsurface-74755b64b169a7d161cd42c672ca45fcdeb5f028.tar.gz
build-system: Add CMakeLists.txt to map-widget
In order to make the central CMakeLists cleaner and more consistent add a CMakeLists.txt to map-widget, like in other root directories. Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd005a61d..b2211c477 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -278,6 +278,7 @@ add_subdirectory(core)
add_subdirectory(qt-models)
add_subdirectory(commands)
add_subdirectory(profile-widget)
+add_subdirectory(map-widget)
if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
add_subdirectory(desktop-widgets)
@@ -304,7 +305,6 @@ if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
mobile-widgets/qml/kirigami/src/libkirigami/tabletmodewatcher.cpp
subsurface-mobile-main.cpp
subsurface-helper.cpp
- map-widget/qmlmapwidgethelper.cpp
)
include_directories(${CMAKE_SOURCE_DIR}/mobile-widgets/qml/kirigami/src/libkirigami)
add_definitions(-DKIRIGAMI_BUILD_TYPE_STATIC)
@@ -324,6 +324,7 @@ if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
target_link_libraries(
${SUBSURFACE_TARGET}
subsurface_profile
+ subsurface_mapwidget
subsurface_models_mobile
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
@@ -346,6 +347,7 @@ elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
subsurface_interface
subsurface_profile
subsurface_statistics
+ subsurface_mapwidget
subsurface_models_desktop
subsurface_commands_desktop
subsurface_corelib