summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-07-11 11:34:33 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-12 08:08:00 -0700
commit8cc0b6dbc14d26cd0fff14b7f0368b33433a0191 (patch)
tree9186fb9f7088f93ae0d7e0550e879a7c15a3955c /CMakeLists.txt
parenta56a7c51f656f9cd7fbcf00b2d0c19d0e74ec701 (diff)
downloadsubsurface-8cc0b6dbc14d26cd0fff14b7f0368b33433a0191.tar.gz
ssrf: add shared helper file
add subsurface-helper.cpp to share functions between mobile and desktop move mobile qml registrations to a shared function (avoiding differences in registrations) Target is to replace current subsurface-desktop-main + subsurface-desktop-helper and subsurface-mobile-main + subsurface-mobile-helper with subsurface-*-main + subsurface-helper Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 034c89c17..87c9db4e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -291,6 +291,7 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
mobile-widgets/qml/kirigami/src/libkirigami/tabletmodewatcher.cpp
subsurface-mobile-main.cpp
subsurface-mobile-helper.cpp
+ subsurface-helper.cpp
profile-widget/qmlprofile.cpp
map-widget/qmlmapwidgethelper.cpp
)
@@ -315,6 +316,7 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
set(SUBSURFACE_APP
subsurface-desktop-main.cpp
subsurface-desktop-helper.cpp
+ subsurface-helper.cpp
)
source_group("Subsurface App" FILES ${SUBSURFACE_APP})
if(ANDROID)