summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-12-14 21:56:31 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-24 08:44:23 +0900
commit9c52aaf043753dbb594c7420f776c836215dd6d2 (patch)
tree86c181dd37d79e00d023a755caa1841ab03339bf /CMakeLists.txt
parent7181b7bcd1d63f4d0ba705a4688bc43ec0b27d8a (diff)
downloadsubsurface-9c52aaf043753dbb594c7420f776c836215dd6d2.tar.gz
build-system: move exportfuncs to backend-shared
WARNING: multi directory commit, needed to secure it builds. move the core/exportfuncs.* to backend-shared. update backend-shared/CMakeLists.txt to generate backend-shared lib update CMakeLists.txt to include backend-shared lib in link process. update ios project to reflect new directory Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55589f830..f032c6c45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -312,6 +312,7 @@ if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
subsurface_mobile
subsurface_profile
subsurface_mapwidget
+ subsurface_backend_shared
subsurface_models_mobile
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
@@ -335,6 +336,7 @@ elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
subsurface_profile
subsurface_statistics
subsurface_mapwidget
+ subsurface_backend_shared
subsurface_models_desktop
subsurface_commands_desktop
subsurface_corelib