summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2016-08-14 08:03:50 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-08-14 09:35:12 -0700
commitaf282a6061d77d5ac830f20baf5db6dad152dbdd (patch)
tree76dcbfdc783107b247ff90dce935e850c204d675 /CMakeLists.txt
parent24718adfc3c2d7caaddd307289ba69fa706315c9 (diff)
downloadsubsurface-af282a6061d77d5ac830f20baf5db6dad152dbdd.tar.gz
Don't build kirigami in the source tree
Instead build it in its own build tree, where it belongs. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dea200c36..a824d0364 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -240,7 +240,7 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
endif()
ADD_LIBRARY(kirigami_static_library STATIC IMPORTED)
SET_TARGET_PROPERTIES(kirigami_static_library PROPERTIES
- IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/mobile-widgets/qml/kirigami/build/src/libkirigamiplugin.a)
+ IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/../kirigami-build/src/libkirigamiplugin.a)
target_link_libraries(
${SUBSURFACE_TARGET}
subsurface_profile