summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2019-10-14 16:08:22 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-10-16 10:57:32 -0700
commitef3d67be081545da4cf3c28497e0e96b3b1c350d (patch)
treeb7ab6b6c4b2c6de0a1cf8e2b2f334bc17e100072 /CMakeLists.txt
parent754fffc795974802dc5082cb22fd163b90eef73d (diff)
downloadsubsurface-ef3d67be081545da4cf3c28497e0e96b3b1c350d.tar.gz
GitHub Actions: add Linux Qt 5.12 container build
The AppImage works - I just need to figure out how to post releases. For now it'a available on the Actions page as Artifact. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 478712f46..d618106d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,11 @@ if (POLICY CMP0071)
cmake_policy(SET CMP0071 OLD)
endif()
+# support Packagename_ROOT environment variable
+if (POLICY CMP0074)
+ cmake_policy(SET CMP0074 NEW) # CMake 3.12
+endif ()
+
# global settings
set(CMAKE_MODULE_PATH