summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-02-03 10:57:57 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-02-03 10:58:00 -0800
commitf563f736078ac3dfbb999b6c2e2352defd729f62 (patch)
treeed7bf93ec43f7d229ee2fc685e201fa0c013af49 /CMakeLists.txt
parenta959e437a99e5048e5314a3759158eec332c0821 (diff)
downloadsubsurface-f563f736078ac3dfbb999b6c2e2352defd729f62.tar.gz
Fix build breakage with earlier Qt versions
In order to get the translations right for Windows we now explicitly pull in a lot more translation files - some of which don't exist in earlier Qt versions. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d32606149..078de5c7c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -331,6 +331,7 @@ set(DOCFILES
${CMAKE_BINARY_DIR}/Documentation/user-manual_ru.html
)
+# add all the translations that we may need
FILE(STRINGS "subsurface_enabled_translations" QTTRANSLATIONS_BASE)
if(NOT DEFINED QT_TRANSLATION_DIR OR QT_TRANSLATION_DIR STREQUAL "")
@@ -339,7 +340,9 @@ endif()
set(QTTRANSLATIONS "")
foreach(QTTRANSLATION ${QTTRANSLATIONS_BASE})
if(NOT ${QTTRANSLATION} STREQUAL "")
- set(QTTRANSLATIONS ${QTTRANSLATIONS} ${QT_TRANSLATION_DIR}/${QTTRANSLATION})
+ if(EXISTS ${QT_TRANSLATION_DIR}/${QTTRANSLATION})
+ set(QTTRANSLATIONS ${QTTRANSLATIONS} ${QT_TRANSLATION_DIR}/${QTTRANSLATION})
+ endif()
endif()
endforeach()