summaryrefslogtreecommitdiffstats
path: root/backend-shared/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-12-14 21:56:31 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-24 08:44:23 +0900
commit9c52aaf043753dbb594c7420f776c836215dd6d2 (patch)
tree86c181dd37d79e00d023a755caa1841ab03339bf /backend-shared/CMakeLists.txt
parent7181b7bcd1d63f4d0ba705a4688bc43ec0b27d8a (diff)
downloadsubsurface-9c52aaf043753dbb594c7420f776c836215dd6d2.tar.gz
build-system: move exportfuncs to backend-shared
WARNING: multi directory commit, needed to secure it builds. move the core/exportfuncs.* to backend-shared. update backend-shared/CMakeLists.txt to generate backend-shared lib update CMakeLists.txt to include backend-shared lib in link process. update ios project to reflect new directory Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'backend-shared/CMakeLists.txt')
-rw-r--r--backend-shared/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/backend-shared/CMakeLists.txt b/backend-shared/CMakeLists.txt
index 750d22a98..b6502bfdf 100644
--- a/backend-shared/CMakeLists.txt
+++ b/backend-shared/CMakeLists.txt
@@ -1,2 +1,9 @@
# backend functionality shared between Desktop (UI) and Mobile (QML)
+set(BACKEND_SRCS
+ exportfuncs.cpp
+ exportfuncs.h
+)
+
+add_library(subsurface_backend_shared STATIC ${BACKEND_SRCS})
+target_link_libraries(subsurface_backend_shared ${QT_LIBRARIES})