summaryrefslogtreecommitdiffstats
path: root/backend-shared/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-12-14 23:12:26 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-24 08:44:23 +0900
commit7751ec1c78642ffcc470ad8714a87851fd5b069d (patch)
tree9846edde60477f36d95839c4f7383de380e3f497 /backend-shared/CMakeLists.txt
parent9c52aaf043753dbb594c7420f776c836215dd6d2 (diff)
downloadsubsurface-7751ec1c78642ffcc470ad8714a87851fd5b069d.tar.gz
build-system: move plannerShared to backend-shared
WARNING: multi directory commit, needed to secure it builds. move the core/plannerShared.* to backend-shared. update CMakeLists.txt to include backend-shared lib in link process. update ios project to reflect new directory Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'backend-shared/CMakeLists.txt')
-rw-r--r--backend-shared/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/backend-shared/CMakeLists.txt b/backend-shared/CMakeLists.txt
index b6502bfdf..fdfdb1e05 100644
--- a/backend-shared/CMakeLists.txt
+++ b/backend-shared/CMakeLists.txt
@@ -3,6 +3,8 @@
set(BACKEND_SRCS
exportfuncs.cpp
exportfuncs.h
+ plannershared.cpp
+ plannershared.h
)
add_library(subsurface_backend_shared STATIC ${BACKEND_SRCS})