summaryrefslogtreecommitdiffstats
path: root/commands/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2019-11-24 13:26:29 +0100
committerGravatar bstoeger <32835590+bstoeger@users.noreply.github.com>2019-12-04 13:00:23 +0100
commit7787bfbf9e39595d98c459e4af121f3174762c7d (patch)
tree6791a300e342ad9b87edcb4781f56f9712e411f3 /commands/CMakeLists.txt
parentd0b3a06e036cf5523cf03c22ec698742bd01048a (diff)
downloadsubsurface-7787bfbf9e39595d98c459e4af121f3174762c7d.tar.gz
Selection: move commands/command_private.* to core/selection.*
The file command_private.cpp had functions concerning selections only. To make these functions accessible from outside the undo machinery, turn it into a part of the core-library. Currently, only C++ functions are exported. We might think about also exporting a C interface. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'commands/CMakeLists.txt')
-rw-r--r--commands/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/commands/CMakeLists.txt b/commands/CMakeLists.txt
index 76ad42603..dcf7f3892 100644
--- a/commands/CMakeLists.txt
+++ b/commands/CMakeLists.txt
@@ -14,8 +14,6 @@ set(SUBSURFACE_GENERIC_COMMANDS_SRCS
command_edit.h
command_edit_trip.cpp
command_edit_trip.h
- command_private.cpp
- command_private.h
)
if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
add_library(subsurface_commands_desktop STATIC ${SUBSURFACE_GENERIC_COMMANDS_SRCS})