summaryrefslogtreecommitdiffstats
path: root/commands/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2019-11-13 15:08:40 +0100
committerGravatar bstoeger <32835590+bstoeger@users.noreply.github.com>2019-11-14 21:02:07 +0100
commit5e29245e689fe9401ee1c33ebb07c601ce25e8c6 (patch)
treea656bcb0e9357b8cab78c5ad196fc6e5a4da4c31 /commands/CMakeLists.txt
parent685b92b9c2ddd6575ae5df7c95b928e60fcd7005 (diff)
downloadsubsurface-5e29245e689fe9401ee1c33ebb07c601ce25e8c6.tar.gz
Refactoring: move undo commands to top level
In the future we might want to use undo-commands for mobile as well (even if not implementing undo). Therefore, move the undo-command source from desktop-widgets to their own commands top-level folder. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'commands/CMakeLists.txt')
-rw-r--r--commands/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/commands/CMakeLists.txt b/commands/CMakeLists.txt
new file mode 100644
index 000000000..76ad42603
--- /dev/null
+++ b/commands/CMakeLists.txt
@@ -0,0 +1,26 @@
+# the undo-commands that perform undoable actions.
+
+# models used both mobile and desktop builds
+set(SUBSURFACE_GENERIC_COMMANDS_SRCS
+ command_base.cpp
+ command_base.h
+ command.cpp
+ command.h
+ command_divelist.cpp
+ command_divelist.h
+ command_divesite.cpp
+ command_divesite.h
+ command_edit.cpp
+ command_edit.h
+ command_edit_trip.cpp
+ command_edit_trip.h
+ command_private.cpp
+ command_private.h
+)
+if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
+ add_library(subsurface_commands_desktop STATIC ${SUBSURFACE_GENERIC_COMMANDS_SRCS})
+ target_link_libraries(subsurface_commands_desktop ${QT_LIBRARIES})
+#elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
+# add_library(subsurface_commands_mobile STATIC ${SUBSURFACE_GENERIC_COMMANDS_SRCS})
+# target_link_libraries(subsurface_commands_mobile ${QT_LIBRARIES})
+endif()