summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-08-06 19:39:35 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-13 11:49:32 -0700
commit63fa532b1520bb18eff98c10ff708834939d8e59 (patch)
treeaf14c8c0536668f4c6784059baf41fbfe4500dcc /core/CMakeLists.txt
parent8603a7d826a7bcf10dea0f93d564a609aae0050a (diff)
downloadsubsurface-63fa532b1520bb18eff98c10ff708834939d8e59.tar.gz
core: create qPrefLanguage from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct preferences - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 9babe1931..7c2af9626 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -109,6 +109,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefDiveComputer.cpp
settings/qPrefDivePlanner.cpp
settings/qPrefFacebook.cpp
+ settings/qPrefLanguage.cpp
settings/qPrefLocationService.cpp
settings/qPrefPrivate.cpp
settings/qPrefProxy.cpp