summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-08-10 21:18:40 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-14 07:12:41 -0700
commit881395318c6960acc59ed1dbb4eb3de5de473cfd (patch)
treedead1a8595291248f430c29ed09e649a70d97e25 /core/CMakeLists.txt
parentc912ac053e1f6705951dbdebba2d883ed2aced92 (diff)
downloadsubsurface-881395318c6960acc59ed1dbb4eb3de5de473cfd.tar.gz
core: create qPrefPartialPressureGas from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct diveComputer - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 943d56898..4105b3549 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -112,6 +112,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefGeocoding.cpp
settings/qPrefLanguage.cpp
settings/qPrefLocationService.cpp
+ settings/qPrefPartialPressureGas.cpp
settings/qPrefPrivate.cpp
settings/qPrefProxy.cpp
settings/qPrefTechnicalDetails.cpp