summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-10-06 07:52:17 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-10-07 10:06:47 -0700
commit56c82081a537e6c15edd2d58567fb8874d4a9f04 (patch)
tree0bd02a0f51793234202ea89facb1edb8807f3eb3 /core/CMakeLists.txt
parent7aacaf60da7e73b9c57012e1846f709acb4d0ac2 (diff)
downloadsubsurface-56c82081a537e6c15edd2d58567fb8874d4a9f04.tar.gz
Make compile succeed without BT_SUPPORT
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index b4b6d76db..03a8c4fc4 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -21,17 +21,16 @@ endif()
if(BTSUPPORT)
add_definitions(-DBT_SUPPORT)
set(BT_SRC_FILES desktop-widgets/btdeviceselectiondialog.cpp)
- set(BT_CORE_SRC_FILES qtserialbluetooth.cpp)
+ set(BT_CORE_SRC_FILES qtserialbluetooth.cpp btdiscovery.cpp)
endif()
if(BLESUPPORT)
add_definitions(-DBLE_SUPPORT)
- set(BT_CORE_SRC_FILES qt-ble.cpp)
+ set(BT_CORE_SRC_FILES ${BT_CORE_SRC_FILES} qt-ble.cpp)
endif()
# compile the core library, in C.
set(SUBSURFACE_CORE_LIB_SRCS
- btdiscovery.cpp
cochran.c
datatrak.c
deco.c