summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christof Arnosti <charno@charno.ch>2020-03-10 22:58:24 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-03-10 17:42:54 -0700
commitcb28158b9abe10f08142f12f11ddbb5d23686fd5 (patch)
tree1d3aec604dfe116accf10326a3f4fe2cca3bf975 /core/CMakeLists.txt
parentb6163804fd56acf23bf6156a84cad02bc6f6eb08 (diff)
downloadsubsurface-cb28158b9abe10f08142f12f11ddbb5d23686fd5.tar.gz
Add timestamps to libdivecomputer.log
Since I learned while trying to implement this that getting sub-second resolution time in portable C99 is hard (especially for someone who is used to the comfort of std::chrono and Howard Hinnants date library) the timer-implemetation from libdivecomputer is now copied to the subsurface source. Signed-off-by: Christof Arnosti <charno@charno.ch>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 58ffa67e4..d325f9280 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -159,6 +159,8 @@ set(SUBSURFACE_CORE_LIB_SRCS
taxonomy.c
taxonomy.h
time.c
+ timer.c
+ timer.h
trip.c
trip.h
uemis-downloader.c