summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-08-05 15:59:28 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-12 11:30:19 -0700
commit2b11fd4cc8fca46152bc8c3c0b53658694cfd5bf (patch)
treefc6d6cbf8a21c71a3aca593b8f958881e5e75084 /core/CMakeLists.txt
parentc42a6e402786c17d2c650cd8d10d24a88e2a1a28 (diff)
downloadsubsurface-2b11fd4cc8fca46152bc8c3c0b53658694cfd5bf.tar.gz
core: create qPrefLocationService from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct prefs - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 61fb09705..9babe1931 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -109,6 +109,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefDiveComputer.cpp
settings/qPrefDivePlanner.cpp
settings/qPrefFacebook.cpp
+ settings/qPrefLocationService.cpp
settings/qPrefPrivate.cpp
settings/qPrefProxy.cpp
settings/qPrefTechnicalDetails.cpp