summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-07-12 10:15:09 +0200
committerGravatar jan Iversen <jani@apache.org>2018-07-12 19:07:49 +0200
commit3a314c3dec7e3f383dec458f5edd150f3df87b9d (patch)
tree325b0a1ebafeffb3ef7ad82ceb6869663bb61463 /core/CMakeLists.txt
parent859b2dcfa4eb4be710d68ad97ef62f4cf6c53a57 (diff)
downloadsubsurface-3a314c3dec7e3f383dec458f5edd150f3df87b9d.tar.gz
core: copy Animations from SettingsObjectWrapper to qPref as its own class
Update set/get functions to follow common name scheme: - get function have same name as in struct preferences - set function have set_<name in struct preferences> - signal function have <name in struct preferences>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 67f0623a7..5b476c779 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -100,6 +100,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
# classes to manage struct preferences for QWidget and QML
settings/qPref.cpp
+ settings/qPrefAnimations.cpp
settings/qPrefDisplay.cpp
#Subsurface Qt have the Subsurface structs QObjectified for easy access via QML.