summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-07-23 15:10:40 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-27 12:36:20 -0700
commite0f1817fdc3b0024c5e97cfa0db048384aae6d78 (patch)
tree358c902fef4bd151cf57bf44ca97662ff9c82cdd /core/CMakeLists.txt
parent75661186d37ac48201cce4e89973658b440aeb72 (diff)
downloadsubsurface-e0f1817fdc3b0024c5e97cfa0db048384aae6d78.tar.gz
core: create qPrefFacebook from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct diveComputer - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index c14ad1aa6..52470d414 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -104,6 +104,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefCloudStorage.cpp
settings/qPrefDisplay.cpp
settings/qPrefDiveComputer.cpp
+ settings/qPrefFacebook.cpp
settings/qPrefPrivate.cpp
#Subsurface Qt have the Subsurface structs QObjectified for easy access via QML.