summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2020-04-17 16:49:15 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-05-06 13:58:09 -0700
commitfe82cb32b93e906b9bf53010538651b9c84df9db (patch)
tree91d944915294c37136221074e31e8077cefc52ad /core/CMakeLists.txt
parent6f8cc5aafecdbbd824be8872c6c4d837d725ef40 (diff)
downloadsubsurface-fe82cb32b93e906b9bf53010538651b9c84df9db.tar.gz
media: add small C++ helper describing a picture struct
By using a std::string instead of a C-string, memory management becomes so much simpler! This class will be used for keeping track of deleted/added pictures in the undo system. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 7699877bc..4a498cde8 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -127,6 +127,8 @@ set(SUBSURFACE_CORE_LIB_SRCS
parse.h
picture.c
picture.h
+ pictureobj.cpp
+ pictureobj.h
planner.c
planner.h
plannernotes.c