summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-08-03 19:24:53 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-09 08:45:02 -0700
commite673a3558eaff6ebc617e6e97e5c81cd819e7985 (patch)
treea8fea97229881c20365bc4e23ba840bf90d78f61 /core/CMakeLists.txt
parente3008c893a72b02d394fbe309d61325651899fa8 (diff)
downloadsubsurface-e673a3558eaff6ebc617e6e97e5c81cd819e7985.tar.gz
core: create qPrefUpdateManager from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct diveComputer - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index b4dd96616..b5a51fc88 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -112,6 +112,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefPrivate.cpp
settings/qPrefProxy.cpp
settings/qPrefUnit.cpp
+ settings/qPrefUpdateManager.cpp
#Subsurface Qt have the Subsurface structs QObjectified for easy access via QML.
subsurface-qt/DiveObjectHelper.cpp