summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-01-22 13:25:58 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-01-24 09:51:02 -0800
commitee5a1564980acfa9c3aa0dbf457f4bdce0efbfcd (patch)
tree1bf11b8fb2c469b9be8d93e9fc71e68f52c229fc /core/CMakeLists.txt
parent1ecd5065a0f821bb9406b5f651ebf6db5d6c2040 (diff)
downloadsubsurface-ee5a1564980acfa9c3aa0dbf457f4bdce0efbfcd.tar.gz
core: move GPX parsing into core
This shouldn't be part of the desktop UI code; there's still the issue that we really shouldn't hand code XML parsing, but I'll leave that for later. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 381276e30..80fbd326e 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -119,6 +119,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
metrics.cpp
metrics.h
ostctools.c
+ parse-gpx.cpp
parse-xml.c
parse.c
parse.h