summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2020-05-26 18:32:52 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-09-29 16:13:03 -0700
commit937fdb500b94244b2da0d72776d939e78a56fa33 (patch)
tree6faeafc717b9c9050185280cd76e5c1ec590382a /core/CMakeLists.txt
parent634e26cbcea064d6ef3d7550dacf54196547bedb (diff)
downloadsubsurface-937fdb500b94244b2da0d72776d939e78a56fa33.tar.gz
filter: add primitive filter presets
Add a rudimentary list of filter presets to the core. The list is sorted by name. Access is provided via a C interface so that the presets can be written to the git and XML logs. Internally, the list is realized by a C++ vector for convenience (euphemism for laziness). Morover, a C++ interface is provided for the UI. Currently names of the presets cannot be edited, since this would mean that the order of the list changes. This may be implemented later if required. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 2e84112da..caaa2b74c 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -86,6 +86,8 @@ set(SUBSURFACE_CORE_LIB_SRCS
file.h
filterconstraint.cpp
filterconstraint.h
+ filterpreset.cpp
+ filterpreset.h
format.cpp
format.h
fulltext.cpp