summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-08-06 19:25:06 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-13 15:04:50 -0700
commit3cd698361c3c1a8c8f5e455799d954e76f68d6bc (patch)
treede70beb39890e3c852a3f0acddbcc3aacc71402b /core/CMakeLists.txt
parentd72546e7993914c7dc97fa782ff84d5373beeb50 (diff)
downloadsubsurface-3cd698361c3c1a8c8f5e455799d954e76f68d6bc.tar.gz
core: create qPrefGeocoding from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct preferences - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 7c2af9626..943d56898 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -109,6 +109,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefDiveComputer.cpp
settings/qPrefDivePlanner.cpp
settings/qPrefFacebook.cpp
+ settings/qPrefGeocoding.cpp
settings/qPrefLanguage.cpp
settings/qPrefLocationService.cpp
settings/qPrefPrivate.cpp