summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christof Arnosti <charno@charno.ch>2020-03-05 22:38:33 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-03-07 12:34:43 -0800
commit6e38f85ba7365efd2f27b407cf001b1e10dff1c8 (patch)
tree6504a8634b78523c02c72cf07280a01177785485 /core/CMakeLists.txt
parent6ffb1e3129a95ad30c2a1951373b1001db930ed6 (diff)
downloadsubsurface-6e38f85ba7365efd2f27b407cf001b1e10dff1c8.tar.gz
usb-serial-for-android: Implementation
Implement the libdivecomputer API in Java and create C/JNI translation layer. [Dirk Hohndel: whitespace harmonization - yes, some of this is Java, this still makes it much easier to read for me; also changed the FTDI conditional compilation to make sure we can still use that for mobile-on-desktop if necessary] Signed-off-by: Christof Arnosti <charno@charno.ch> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index d3f1401f1..58ffa67e4 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -2,12 +2,12 @@ set(PLATFORM_SRC unknown_platform.c)
message(STATUS "system name ${CMAKE_SYSTEM_NAME}")
if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
if(ANDROID)
- set(PLATFORM_SRC android.cpp)
+ set(PLATFORM_SRC android.cpp serial_usb_android.cpp)
else()
set(PLATFORM_SRC unix.c)
endif()
elseif(CMAKE_SYSTEM_NAME STREQUAL "Android")
- set(PLATFORM_SRC android.cpp)
+ set(PLATFORM_SRC android.cpp serial_usb_android.cpp)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(PLATFORM_SRC macos.c)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")