summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-11-14 19:44:06 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-12-03 13:26:55 -0800
commit31f0741ecc0013cd361683e7fad9bf2c8c166a13 (patch)
tree84c429abc20c46e7f8340389725b3ee21ec2aee1 /core/CMakeLists.txt
parent25d7c58c07fc4b0bf3bc188f540a4ac66f6cd233 (diff)
downloadsubsurface-31f0741ecc0013cd361683e7fad9bf2c8c166a13.tar.gz
downloader: first outline of downloading dives from a device
This is of course not functional at all, but it gives a first idea of what we will need to do in this code. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 1ed24019c..51ccf608f 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -20,6 +20,10 @@ if(FTDISUPPORT)
set(SERIAL_FTDI serial_ftdi.c)
endif()
+if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DownloaderExecutable")
+ set(DOWNLOADER cli-downloader.cpp)
+endif()
+
if(BTSUPPORT)
add_definitions(-DBT_SUPPORT)
set(BT_SRC_FILES desktop-widgets/btdeviceselectiondialog.cpp)
@@ -252,6 +256,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
${SERIAL_FTDI}
${PLATFORM_SRC}
${BT_CORE_SRC_FILES}
+ ${DOWNLOADER}
)
source_group("Subsurface Core" FILES ${SUBSURFACE_CORE_LIB_SRCS})