summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-07-15 18:15:40 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-25 08:35:04 -0700
commit0002cd2d202c45d520f115280f98ba94c0028815 (patch)
tree8c32db430f9d1f6433c2da4a5bc394f262288478 /core/CMakeLists.txt
parent69c7ed676a7c7806f4132a899f98650fa2ad3dfb (diff)
downloadsubsurface-0002cd2d202c45d520f115280f98ba94c0028815.tar.gz
core: create qPrefDiveComputer from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct diveComputer - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 577c496c9..c14ad1aa6 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -103,6 +103,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefAnimations.cpp
settings/qPrefCloudStorage.cpp
settings/qPrefDisplay.cpp
+ settings/qPrefDiveComputer.cpp
settings/qPrefPrivate.cpp
#Subsurface Qt have the Subsurface structs QObjectified for easy access via QML.