summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Kristaps Dz <kristaps@bsd.lv>2018-07-18 11:04:35 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-28 14:08:06 -0700
commit51066e5478d76824c5da53f37184e0e0d1f3e4af (patch)
tree63cf9ed3de3f2aa0c41b942069ba7fbfb3298062 /core/CMakeLists.txt
parent8da7ddc64badd09e309e39ed79f4b6821d84454e (diff)
downloadsubsurface-51066e5478d76824c5da53f37184e0e0d1f3e4af.tar.gz
Build-system: add OpenBSD support
Rename linux.c to unix.c and add OpenBSD support as well. Conditionally compile based on OS. Signed-off-by: Kristaps Dzonsons <kristaps@bsd.lv>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 52470d414..dbaa3bbe5 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -4,7 +4,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
if(ANDROID)
set(PLATFORM_SRC android.cpp)
else()
- set(PLATFORM_SRC linux.c)
+ set(PLATFORM_SRC unix.c)
endif()
elseif(CMAKE_SYSTEM_NAME STREQUAL "Android")
set(PLATFORM_SRC android.cpp)
@@ -12,6 +12,8 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(PLATFORM_SRC macos.c)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")
set(PLATFORM_SRC windows.c)
+elseif(CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
+ set(PLATFORM_SRC unix.c)
endif()
if(FTDISUPPORT)