summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tcanabrava@kde.org>2018-10-13 11:52:08 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-12-14 01:05:18 +0800
commit19f6e8810cdaedcbecd87aa762c75e59bebe26c9 (patch)
treecae987dfcd04090530375d5ec9bb98d174d1b128 /desktop-widgets/CMakeLists.txt
parentc64c9c923b1f2a4758f3ff639c28790f99c9ce84 (diff)
downloadsubsurface-19f6e8810cdaedcbecd87aa762c75e59bebe26c9.tar.gz
Start to implement a simplified version of the filter widget
The idea of this new widget is to be able to filter more types of data, while keeping it simple and extending the feature set to something that was impossible with the old implementation. While the old implementation had 4 panels that you could use to filter specific tags / people / types of dives the new one will let you filter by visibility, temperature people, name, equipment, etc, in a more natural way than the old one. Signed-off-by: Tomaz Canabrava <tcanabrava@kde.org>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index 519061ac0..149ba32c0 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -34,6 +34,7 @@ set (SUBSURFACE_UI
diveshareexportdialog.ui
downloadfromdivecomputer.ui
filterwidget.ui
+ filterwidget2.ui
findmovedimagesdialog.ui
listfilter.ui
locationInformation.ui
@@ -90,6 +91,7 @@ set(SUBSURFACE_INTERFACE
command_divelist.cpp
locationinformation.cpp
qtwaitingspinner.cpp
+ filterwidget2.cpp
tab-widgets/TabDiveStatistics.cpp
tab-widgets/TabDiveInformation.cpp
tab-widgets/TabDivePhotos.cpp