summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2018-07-23 23:41:23 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-10-11 16:22:27 -0700
commit43c3885249fb867e7c33c8b3b5846d44e908774f (patch)
tree3675041ca82295a94c3bc48e9812e26543faacae /desktop-widgets/CMakeLists.txt
parentf427226b3b605523bc8285dbdaaa7f6993af6e6a (diff)
downloadsubsurface-43c3885249fb867e7c33c8b3b5846d44e908774f.tar.gz
Undo: isolate undo-commands
This refactors the undo-commands (which are now only "commands"). - Move everything in namespace Command. This allows shortening of names without polluting the global namespace. Moreover, the prefix Command:: will immediately signal that the undo-machinery is invoked. This is more terse than UndoCommands::instance()->... - Remove the Undo in front of the class-names. Creating an "UndoX" object to do "X" is paradoxical. - Create a base class for all commands that defines the Qt-translation functions. Thus all translations end up in the "Command" context. - Add a workToBeDone() function, which signals whether this should be added to the UndoStack. Thus the caller doesn't have to check itself whether this any work will be done. Note: Qt5.9 introduces "setObsolete" which does the same. - Split into public and internal header files. In the public header file only export the function calls, thus hiding all implementation details from the caller. - Split in different translation units: One for the stubs, one for the base classes and one for groups of commands. Currently, there is only one class of commands: divelist-commands. - Move the undoStack from the MainWindow class into commands_base.cpp. If we want to implement MDI, this can easily be moved into an appropriate Document class. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index f5da2ae84..519061ac0 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -85,7 +85,9 @@ set(SUBSURFACE_INTERFACE
divepicturewidget.cpp
usersurvey.cpp
configuredivecomputerdialog.cpp
- undocommands.cpp
+ command.cpp
+ command_base.cpp
+ command_divelist.cpp
locationinformation.cpp
qtwaitingspinner.cpp
tab-widgets/TabDiveStatistics.cpp