summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2019-04-13 17:43:45 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-04-15 10:30:04 +1200
commitfe61f6b69e03d4700e28724e6977e9b365541724 (patch)
tree56626b89e24253f9df678b4d6a735d299696be33 /desktop-widgets/CMakeLists.txt
parent4bb002d1370a9eb4ebe5a1210b969edc5cdba893 (diff)
downloadsubsurface-fe61f6b69e03d4700e28724e6977e9b365541724.tar.gz
Cleanup: Move dive-equipment tab into own translation units
Most tabs in the dive-information widget have there own translation units and ui-files. Only the equipment tab was married with the main tab. Move it out to get more reasonably sized translation units and some isolation. Currently, this needs ugly hacks when entering / checking for edit mode: Access to MainTab is via the MainWindow. And vice/versa, when accessing the DiveEquipmentTab from the MainTab, the former is hardcoded as the first item of an array. These hacks will soon be removed though, when making equipment editing undoable. The tabs will then be independent. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index b86bd0524..fbaff1d6c 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -48,6 +48,7 @@ set (SUBSURFACE_UI
tab-widgets/TabDiveInformation.ui
tab-widgets/TabDivePhotos.ui
tab-widgets/TabDiveExtraInfo.ui
+ tab-widgets/TabDiveEquipment.ui
tab-widgets/TabDiveSite.ui
)
@@ -118,6 +119,8 @@ set(SUBSURFACE_INTERFACE
tab-widgets/TabBase.h
tab-widgets/TabDiveExtraInfo.cpp
tab-widgets/TabDiveExtraInfo.h
+ tab-widgets/TabDiveEquipment.cpp
+ tab-widgets/TabDiveEquipment.h
tab-widgets/TabDiveInformation.cpp
tab-widgets/TabDiveInformation.h
tab-widgets/TabDivePhotos.cpp