summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2019-02-24 21:22:33 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-04-12 18:19:07 +0300
commitd7d408a99e7459ec1a5fc2d9953e72924054b834 (patch)
tree2f283ef63c4e5c0352b648374f99043530b4520c /desktop-widgets/CMakeLists.txt
parent9fd87fa08081116ba12812ddea0a43be61019cbb (diff)
downloadsubsurface-d7d408a99e7459ec1a5fc2d9953e72924054b834.tar.gz
Undo: implement undo of dive trip editing
This is copying the dive editing code. It uses an OO design with virtual functions for getting and setting the values. It doesn't use templates though, as both fields of strig type. This feels a bit over-engineered, but it is 1) consistent with the dive edit code and 2) the number / types of dive trip fields might increase. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index f3718935f..b86bd0524 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -66,6 +66,8 @@ set(SUBSURFACE_INTERFACE
command_divesite.h
command_edit.cpp
command_edit.h
+ command_edit_trip.cpp
+ command_edit_trip.h
command_private.cpp
command_private.h
configuredivecomputerdialog.cpp