summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-08 16:28:56 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-08 16:31:38 -0800
commit871f585f42fd59199d5c616fa93d6eb1037b445a (patch)
tree4a827ec11a30d9a57fe713cb2ba3a510682f7ffe /desktop-widgets/CMakeLists.txt
parent125217074e61ff25b901a05004208ccb21f121ce (diff)
downloadsubsurface-871f585f42fd59199d5c616fa93d6eb1037b445a.tar.gz
Make building plugins optional
This currently fails at least on my old Mac that I use to create binaries that work on 10.7 and newer. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index d8f5cd5a9..a2beffa5c 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -13,7 +13,9 @@ include_directories(.
)
add_subdirectory(preferences)
-add_subdirectory(plugins)
+if(NOT DISABLE_PLUGINS)
+ add_subdirectory(plugins)
+endif()
# the interface, in C++
set(SUBSURFACE_INTERFACE