summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-09-17 14:04:27 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-30 10:36:49 -0700
commitb35ccc3a3533a3fcf9c7434584470537b6d0001e (patch)
tree8b8b4ebbb7c9e705c430fb5c9d38c40fa6cf386a /desktop-widgets/CMakeLists.txt
parent225ac07005e72d52b1f70ae88e7033528789fc21 (diff)
downloadsubsurface-b35ccc3a3533a3fcf9c7434584470537b6d0001e.tar.gz
Preferences: start to port preferences to a more sane design
Our preferences dialog right now is a rather huge dialog with more than 9 subpages, and all of those pages are programmed inside of the same class, same methods and all that - which means that if I change something on the dialog I can break any other thing quite easily. The idea of this patch series is to make it harder to break user settings and the settings dialog. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index 635a8b68e..6d9051b10 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -13,6 +13,8 @@ include_directories(.
${CMAKE_BINARY_DIR}
)
+add_subdirectory(preferences)
+
# the interface, in C++
set(SUBSURFACE_INTERFACE
updatemanager.cpp