summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2020-09-29 23:19:11 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-10-03 10:01:13 -0700
commitf5fe6839c7672f775e35068f46fbb2d2e41b8bf5 (patch)
tree37fe93300f9fb809677d1ad3308ca0d76355b8b6 /desktop-widgets/CMakeLists.txt
parentf4ee8934243d6c924d810b5b2ec5a6c1f3b492f8 (diff)
downloadsubsurface-f5fe6839c7672f775e35068f46fbb2d2e41b8bf5.tar.gz
desktop: add trip selection dialog
A simple dialog to select a trip. Simply fill a QListWidget without the model/view rigmarole. So much less painful! Of course that means that the dialog has to be regenerated everytime it is used. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index 5a1418d76..9531688d7 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -43,6 +43,7 @@ set (SUBSURFACE_UI
shifttimes.ui
tableview.ui
templateedit.ui
+ tripselectiodialog.ui
urldialog.ui
webservices.ui
tab-widgets/maintab.ui
@@ -130,6 +131,8 @@ set(SUBSURFACE_INTERFACE
tagwidget.h
textedit.cpp
textedit.h
+ tripselectiondialog.cpp
+ tripselectiondialog.h
updatemanager.cpp
updatemanager.h
)