summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2020-05-17 12:07:04 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-09-29 16:13:03 -0700
commitc0af74ba88c0101a820da945b96258932c27bab5 (patch)
treebc2546400d325414dbd9fb6256677052d50426ed /desktop-widgets/CMakeLists.txt
parentaf9d379a4147b01ea599c86e0ff001cace926c1c (diff)
downloadsubsurface-c0af74ba88c0101a820da945b96258932c27bab5.tar.gz
filter: add a filter constraint widget
This add a widget that represents a single filter constraint. Since filter constraints are very general, the widget has to consider a number of cases: - numerical ranges - star-widget ranges - string lists - multiple choice lists Moreover, it supports units, which must be updated when the preferences change. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index 1de8914ee..a9a6a59a7 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -77,6 +77,8 @@ set(SUBSURFACE_INTERFACE
divesiteimportdialog.h
downloadfromdivecomputer.cpp
downloadfromdivecomputer.h
+ filterconstraintwidget.cpp
+ filterconstraintwidget.h
filterwidget2.cpp
filterwidget2.h
findmovedimagesdialog.cpp