summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2019-01-25 18:27:31 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-04-12 18:19:07 +0300
commit9e603cbe2bbcae1822859b284c39dd804bf321fb (patch)
tree9b4091c07aeea8b4abe65593ab07abc2c7326a52 /desktop-widgets/CMakeLists.txt
parent8858bfa1f8cf30cc4eb070fb6e709f7051e61241 (diff)
downloadsubsurface-9e603cbe2bbcae1822859b284c39dd804bf321fb.tar.gz
Undo: implement rudimentary undo of dive-notes editing
Implement a first rudimentary dive-editing command. The main code resides in a base class Command::Edit, which calls virtual functions to read / set the fields and extract the field name. Implement an example: editing of dive notes. This dose not yet update the UI on undo / redo. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index c451c46ef..2b1f07d1b 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -64,6 +64,8 @@ set(SUBSURFACE_INTERFACE
command_divelist.h
command_divesite.cpp
command_divesite.h
+ command_edit.cpp
+ command_edit.h
configuredivecomputerdialog.cpp
configuredivecomputerdialog.h
divecomputermanagementdialog.cpp