summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-11-09 18:57:47 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-09 18:00:56 -0800
commitc71df5baa5fb161a7d873912d27773ab8b2e4212 (patch)
tree878fd4e5dd8533844f360c16a01ab353a14c551a /desktop-widgets/CMakeLists.txt
parente1d43ade275313f643b27b2c30fd372f6c6ccd02 (diff)
downloadsubsurface-c71df5baa5fb161a7d873912d27773ab8b2e4212.tar.gz
Don't rely on CMAKE_AUTOUIC
Some old CMakes that we use had problems with it, change to use the qt5_wrap_ui macro that's bundled with Qt. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt35
1 files changed, 34 insertions, 1 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index a2beffa5c..dc5503515 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -17,6 +17,37 @@ if(NOT DISABLE_PLUGINS)
add_subdirectory(plugins)
endif()
+set (SUBSURFACE_UI
+ about.ui
+ btdeviceselectiondialog.ui
+ configuredivecomputerdialog.ui
+ divecomponentselection.ui
+ divecomputermanagementdialog.ui
+ divelogexportdialog.ui
+ divelogimportdialog.ui
+ diveplanner.ui
+ diveshareexportdialog.ui
+ downloadfromdivecomputer.ui
+ filterwidget.ui
+ listfilter.ui
+ locationInformation.ui
+ maintab.ui
+ mainwindow.ui
+ plannerDetails.ui
+ plannerSettings.ui
+ printoptions.ui
+ renumber.ui
+ searchbar.ui
+ setpoint.ui
+ shiftimagetimes.ui
+ shifttimes.ui
+ tableview.ui
+ templateedit.ui
+ urldialog.ui
+ usersurvey.ui
+ webservices.ui
+)
+
# the interface, in C++
set(SUBSURFACE_INTERFACE
updatemanager.cpp
@@ -81,9 +112,11 @@ set(SUBSURFACE_STATISTICS_LIB_SRCS
)
source_group("Subsurface Statistics" FILES ${SUBSURFACE_STATISTICS_LIB_SRCS})
+qt5_wrap_ui(SUBSURFACE_UI_SRCS ${SUBSURFACE_UI})
+
add_library(subsurface_statistics STATIC ${SUBSURFACE_STATISTICS_LIB_SRCS})
target_link_libraries(subsurface_statistics ${QT_LIBRARIES})
add_library(subsurface_generated_ui STATIC ${SUBSURFACE_UI_HDRS})
target_link_libraries(subsurface_generated_ui ${QT_LIBRARIES})
-add_library(subsurface_interface STATIC ${SUBSURFACE_INTERFACE})
+add_library(subsurface_interface STATIC ${SUBSURFACE_INTERFACE} ${SUBSURFACE_UI_SRCS})
target_link_libraries(subsurface_interface ${QT_LIBRARIES} ${MARBLE_LIBRARIES} ${GRANTLEE_LIBRARIES} subsurface_desktop_preferences)