summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2018-12-28 14:14:31 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-04-12 18:19:07 +0300
commit2bb2643ae4d4c1b6d0c32c9a18e2225eed0b5936 (patch)
tree4e0fb81b4fcf677e2efd4712cc4941c1b61f4c9a /desktop-widgets/CMakeLists.txt
parent0882ca64b0867e962b2231aed4fc097e8e5754de (diff)
downloadsubsurface-2bb2643ae4d4c1b6d0c32c9a18e2225eed0b5936.tar.gz
Desktop: create new custom TextEdit widget for notes-field
Currently, the notes field uses a QTextEdit, which doesn't send a signal if it goes out of focus. But for undo of dive-editing we don't want to create an undo object for *every* text change. Thus, create a custom TextEdit widget that derives from QTextEdit and turns the focusOutEvent into a editingFinished signal. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'desktop-widgets/CMakeLists.txt')
-rw-r--r--desktop-widgets/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/desktop-widgets/CMakeLists.txt b/desktop-widgets/CMakeLists.txt
index c494f1a8b..c451c46ef 100644
--- a/desktop-widgets/CMakeLists.txt
+++ b/desktop-widgets/CMakeLists.txt
@@ -126,6 +126,8 @@ set(SUBSURFACE_INTERFACE
tableview.h
tagwidget.cpp
tagwidget.h
+ textedit.cpp
+ textedit.h
updatemanager.cpp
updatemanager.h
usersurvey.cpp