summaryrefslogtreecommitdiffstats
path: root/desktop-widgets/preferences/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar willemferguson <willemferguson@zoology.up.ac.za>2019-12-08 15:44:14 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-25 02:57:42 +0900
commitb24caa4e2db42d300e3806ca3d13ce72202a24d8 (patch)
tree31b0d4c9824427f19ab757ecf185a714ae6b80ac /desktop-widgets/preferences/CMakeLists.txt
parentf63f3eb4ae0cd3621cf5748dfd76749b40b6d886 (diff)
downloadsubsurface-b24caa4e2db42d300e3806ca3d13ce72202a24d8.tar.gz
Preferenced UI: add dive download tab
Add a preferences tab for dive download, allowing resetting the buttons representing download connections in the Download panel. Signed-off-by: willemferguson <willemferguson@zoology.up.ac.za> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'desktop-widgets/preferences/CMakeLists.txt')
-rw-r--r--desktop-widgets/preferences/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/desktop-widgets/preferences/CMakeLists.txt b/desktop-widgets/preferences/CMakeLists.txt
index c0b0de7ab..cec31e6f3 100644
--- a/desktop-widgets/preferences/CMakeLists.txt
+++ b/desktop-widgets/preferences/CMakeLists.txt
@@ -14,6 +14,7 @@ set(SUBSURFACE_PREFERENCES_UI
preferences_language.ui
preferences_media.ui
preferences_equipment.ui
+ preferences_dc.ui
)
qt5_wrap_ui(SUBSURFACE_PREFERENCES_UI_HDRS ${SUBSURFACE_PREFERENCES_UI})
@@ -23,6 +24,10 @@ source_group("Subsurface Interface Files" FILES ${SUBSURFACE_PREFERENCES_UI})
set(SUBSURFACE_PREFERENCES_LIB_SRCS
abstractpreferenceswidget.cpp
abstractpreferenceswidget.h
+ preferences_cloud.cpp
+ preferences_cloud.h
+ preferences_dc.cpp
+ preferences_dc.h
preferences_defaults.cpp
preferences_defaults.h
preferences_equipment.cpp
@@ -37,8 +42,6 @@ set(SUBSURFACE_PREFERENCES_LIB_SRCS
preferences_media.h
preferences_network.cpp
preferences_network.h
- preferences_cloud.cpp
- preferences_cloud.h
preferences_units.cpp
preferences_units.h
preferencesdialog.cpp