summaryrefslogtreecommitdiffstats
path: root/map-widget/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-12-22 14:10:29 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-24 06:18:36 +0900
commit74755b64b169a7d161cd42c672ca45fcdeb5f028 (patch)
treebbbaa744d704467245bdb45f0b068a9b424c311a /map-widget/CMakeLists.txt
parent41d6ff96c173e67654772537eeff3842dd024a53 (diff)
downloadsubsurface-74755b64b169a7d161cd42c672ca45fcdeb5f028.tar.gz
build-system: Add CMakeLists.txt to map-widget
In order to make the central CMakeLists cleaner and more consistent add a CMakeLists.txt to map-widget, like in other root directories. Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'map-widget/CMakeLists.txt')
-rw-r--r--map-widget/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/map-widget/CMakeLists.txt b/map-widget/CMakeLists.txt
new file mode 100644
index 000000000..4f1b5dc33
--- /dev/null
+++ b/map-widget/CMakeLists.txt
@@ -0,0 +1,8 @@
+# map widget to show locations
+
+# library used by mobile build
+set(SUBSURFACE_MAPWIDGET_SRCS
+ qmlmapwidgethelper.cpp
+)
+add_library(subsurface_mapwidget STATIC ${SUBSURFACE_MAPWIDGET_SRCS})
+target_link_libraries(subsurface_mapwidget ${QT_LIBRARIES})